Python

Versione: 
2.7.6
Data rilascio: 
Mercoledì, 17 Dicembre, 1997

Licenza:

Interfaccia:

Linguaggio interpretato orientato agli oggetti.

Usando yum per l'installazione, il pacchetto python fornisce il linguaggio base, i pacchetti python-tools e python-debug mentre i pacchetti PyQt4-* permettono il collegamento tra Python e Qt4.

Questo software è distribuito con due modalità:
  • come pacchetto compresso, da scaricare e installare manualmente; se ci sono prerequisiti da soddisfare, andranno anch'essi scaricati e installati manualmente;
  • come pacchetto RPM, installabile tramite il gestore pacchetti rpm preferito, che provvederà a scaricare e installare sia il software che gli eventuali prerequisiti.
Scegli la modalità di installazione che preferisci, tenendo conto del fatto che non tutte le versioni del software sono disponibili per entrambe le modalità.

Installazione con rpm

Questo programma si può installare usando il gestore pacchetti rpm. Vedi sotto per la stringa di installazione. I prerequisiti richiesti sono gestiti dal gestore pacchetti e, se necessario, scaricati e installati automaticamente.

python-libs-2.7.6-25.oc00 (16/05/2020)
Repository: Netlabs stable
python-devel-2.7.6-25.oc00 (16/05/2020)
Repository: Netlabs stable (note: development files, not needed by the end user)
python-debuginfo-2.7.6-25.oc00 (16/05/2020)
Repository: Netlabs stable
python-test-2.7.6-25.oc00 (16/05/2020)
Repository: Netlabs stable
tkinter-2.7.6-25.oc00 (16/05/2020)
python-2.7.6-25.oc00 (16/05/2020)
Repository: Netlabs stable
changelog * Sat Jun 3 2017 Dmitriy Kuminov <coding@dmik.org> 2.7.6-18 - Put the LIBCx library to LDFLAGS rather than LIBS to have all module DLLs linked against it as well. - Rebuild against LIBCx 0.5.3 to incorporate DosRead JFS workaround for fread. - Remove urpo as it conflicts with LIBCx. - Remove pthread from libraries as not needed any more. - Remove .pyo files (needed only in python -O mode which is rarely used). - Remove .dbg files for Windows stubs (wininst-*.exe). - Use scm_source/scm_setup for downloading sources. Python News +++++++++++ Whats' New in Python 2.7.6? =========================== *Release date: 2013-11-10* Library ------- - Issue #19435: Fix directory traversal attack on CGIHttpRequestHandler. IDLE ---- - Issue #19426: Fixed the opening of Python source file with specified encoding. Tests ----- - Issue #19457: Fixed xmlcharrefreplace tests on wide build when tests are loaded from .py[co] files. Build ----- - Issue #15663: Revert OS X installer built-in Tcl/Tk support for 2.7.6. Some third-party projects, such as Matplotlib and PIL/Pillow, depended on being able to build with Tcl and Tk frameworks in /Library/Frameworks.
python-tools-2.7.6-25.oc00 (16/05/2020)
Repository: Netlabs stable
Python News +++++++++++ Whats' New in Python 2.7.6? =========================== *Release date: 2013-11-10* Library ------- - Issue #19435: Fix directory traversal attack on CGIHttpRequestHandler. IDLE ---- - Issue #19426: Fixed the opening of Python source file with specified encoding. Tests ----- - Issue #19457: Fixed xmlcharrefreplace tests on wide build when tests are loaded from .py[co] files. Build ----- - Issue #15663: Revert OS X installer built-in Tcl/Tk support for 2.7.6. Some third-party projects, such as Matplotlib and PIL/Pillow, depended on being able to build with Tcl and Tk frameworks in /Library/Frameworks.
python2-setuptools-34.4.1-2.oc00 (21/01/2019)
Repository: Netlabs stable
python-libxml2-2.9.8-2.oc00 (18/01/2019)
Repository: Netlabs stable
TODO for the libxml2 Python wrappers $Id$ Things to do: ------------- - SAX interfaces - push is done but no generic interface - elementDecl need some work - need more testing and check full callbacks for xmllib/sgmlop replacement - enums -> libxml.py - access to XPath variables - xmlBuffer exposure - xpathContext, being able to set/get info and clean it up - more work needed on context handling for function lookup and use of an hash table. - add regression tests - SAX flow - DTD element and attributes content accesses - attribute handled in SAX - element needed in both Done: ----- - class hierarchy: + make specific node type inherit from xmlNode done, had to sort the classes in the output + get the generator to output a classes.txt description done libxml2class.txt - add regression tests - tests/Makefile.am: export the Python class path - xpath queries - xpath extension - check memory - build tree - saving - extensions based on a python.xml description of the new specific interfaces file libxml2-python-api.xml , first entry is xmlRegisterXPathFunction - spec file: automatically generate for pythonX.Y if found Done, a bit ugly by running new makes in %install for each level found. - error redirections and preformat - handling of node.content - access to xmlParserCtxt and push mode - needed for SAX too - entry points - wrappers - decent interface for setting/getting behaviour - memory debug interfaces - SAX interfaces - basic stuff with push is available - basic xmllib replacement Daniel Veillard
PyQt4-webkit-4.11.4-3.oc00 (01/07/2016)
Repository: Netlabs stable
v4.11.4 11th June 2015 - Added support for Qt v4.8.7. - Added QWIDGETSIZE_MAX to QtGui. - Added some missing QEvent.Type enum values. - Added the --license-dir command line option to configure-ng.py. - Added the --no-python-dbus command line option to configure-ng.py. - Bug fixes.
PyQt4-doc-4.11.4-3.oc00 (01/07/2016)
Repository: Netlabs stable
PyQt4-4.11.4-3.oc00 (01/07/2016)
Repository: Netlabs stable
v4.11.4 11th June 2015 - Added support for Qt v4.8.7. - Added QWIDGETSIZE_MAX to QtGui. - Added some missing QEvent.Type enum values. - Added the --license-dir command line option to configure-ng.py. - Added the --no-python-dbus command line option to configure-ng.py. - Bug fixes.
PyQt4-qsci-api-4.11.4-3.oc00 (01/07/2016)
Repository: Netlabs stable
v4.11.4 11th June 2015 - Added support for Qt v4.8.7. - Added QWIDGETSIZE_MAX to QtGui. - Added some missing QEvent.Type enum values. - Added the --license-dir command line option to configure-ng.py. - Added the --no-python-dbus command line option to configure-ng.py. - Bug fixes.
python-lxml-3.5.0-1.oc00 (12/12/2015)
Repository: Netlabs stable
============== lxml changelog ============== 3.5.0 (2015-11-13) ================== Bugs fixed ---------- * Unicode string results failed XPath queries in PyPy. * LP#1497051: HTML target parser failed to terminate on exceptions and continued parsing instead. * Deprecated API usage in doctestcompare.
python-magic-5.04-7.oc00 (02/02/2015)
Repository: Netlabs stable
Magic file extensions: libmagic python bindings

Installazione manuale

Il programma è distribuito come pacchetto ZIP: scaricare in una cartella temporanea, scompattare nella cartella di destinazione (preferibilmente in PATH) e impostare le variabili PYTHONHOME e PYTHONPATH in config.sys. Vedi sotto per il(i) link di download.

E' possibile installare i prerequisiti con rpm, eseguendo la stringa seguente in una finestra comandi:

yum install libc libcx libgcc1 libssp libstdc++6 libstdc++ libsupc++6 libsupc++ libgcc-fwd pthread

Qui di seguito trovi i link di download per l'installazione manuale del software:

Scheda aggiornata l'ultima volta il: 16/07/2022 - 11:11

Aggiungi un commento