GNU sed

Versione: 
4.7
Data rilascio: 
Lunedì, 20 Maggio, 2019

Licenza:

Interfaccia:

Authors/Port authors:

GNU sed (stream editor) è un'editor di testo a linea di comando non interattivo.

Sed si usa comunemente per filtrare testo, ad esempio, prende in input del testo, effettua alcune operazioni (o una serie di operazioni) su di esso ed emette il testo modificato. Sed è tipicamente usato per estrarre parti di file utilizzando corrispondenze esatte di caratteri o per  sostituire occorrenze multiple di una stringa all'interno di un file.

Questo software è distribuito con due modalità:
  • come pacchetto compresso, da scaricare e installare manualmente; se ci sono prerequisiti da soddisfare, andranno anch'essi scaricati e installati manualmente;
  • come pacchetto RPM, installabile tramite il gestore pacchetti rpm preferito, che provvederà a scaricare e installare sia il software che gli eventuali prerequisiti.
Scegli la modalità di installazione che preferisci, tenendo conto del fatto che non tutte le versioni del software sono disponibili per entrambe le modalità.

Installazione con rpm

Questo programma si può installare usando il gestore pacchetti rpm. Vedi sotto per la stringa di installazione. I prerequisiti richiesti sono gestiti dal gestore pacchetti e, se necessario, scaricati e installati automaticamente.

sed-4.7-1.oc00 (15/05/2019)
Repository: Netlabs stable
changelog * Wed May 15 2019 Silvan Scherrer <silvan.scherrer@aroa.ch> 4.7-1 - update to vendor version 4.7
sed-debuginfo-4.7-1.oc00 (15/05/2019)
Repository: Netlabs stable

Installazione manuale

Program is distributed as ZIP package: download to temporary directory and unpack to destination folder. See below for download link(s).

Qui di seguito trovi i link di download per l'installazione manuale del software:

Scheda aggiornata l'ultima volta il: 10/09/2019 - 10:23

Commenti

Hello, when trying to compile the lastest TIFF image library, version 4.1.0, I get the infamous "checking for a sed that does not truncate output ... no acceptable sed could be found in $PATH" error. I tried it with both sed-4.X versions that are available at Hobbes. Would you please be so kind to provide a sed version for OS/2 that does not issue this exception ? Thank you. Alex

Aggiungi un commento